maemo的sdk死活装不上

都是些这样的错:
Setting up dbus (1.2.14-0maemo4+0m5) ...
/scratchbox/tools/bin/chgrp: invalid group name `messagebus'
/scratchbox/tools/bin/chown: `messagebus:messagebus': invalid user
mmap: Operation not permitted
/scratchbox/tools/bin/chown: `root:messagebus': invalid group
Setting up hal (0.5.12~git20090219-0maemo9+0m5) ...
mmap: Operation not permitted
dpkg: error processing hal (--configure):
subprocess post-installation script returned error exit status 255
Setting up sudo (1.6.8p12-4osso22+0m5) ...
Updating sudoers
mmap: Operation not permitted
/etc/sudoers.d/01sudo changes break sudoers
dpkg: error processing sudo (--configure):
subprocess post-installation script returned error exit status 1
因为装不上sudo,所以就装不上maemo-core-runtime
dpkg: dependency problems prevent configuration of maemo-core-runtime:
maemo-core-runtime depends on sudo; however:
Package sudo is not configured yet.
最后以一大堆如此的错误而告终。
郁闷。为这个折腾了3、4天了

此博客中的热门博文

少写代码,多读别人写的代码

在windows下使用llvm+clang

tensorflow distributed runtime初窥